file jquery issue on k2 filter page

More
8 months 2 weeks ago #5081 by jenniedee
jquery issue on k2 filter page was created by jenniedee
Hello
I experienced a jquery issue on a site I'm building which uses the Joomlart k2 filter module on one page. I installed jquery easy free plugin and the issue was instantly fixed without adjusting any settings.
However the Ignite gallery I was using on other pages was broken as it needed v 1.12 jquery. This configuration worked for everything but broke the slicknav mobile menu only on the page with the filter module, it worked for everything else.
So I purchased jQuery Easy Profiles so I could apply the different configurations, but for some strange reason none of the jquery versions now seem to work on the filter page. Both the filter and the slicknav menu are broken on this page.
I am puzzled as to why the settings I originally had in the free plugin and which worked, now no longer seem to work. The error I'm getting:
TypeError: jQuery.browser is undefined
The site is not live on the domain, but I've included a 24 hour preview link which I can update if needed:
0f600b9434245ebc32a7c435964d55d8.p.myukc...index.php/properties
Thank you
Best regards
Jennie

Please Log in or Create an account to join the conversation.

More
8 months 2 weeks ago #5082 by syw
Replied by syw on topic jquery issue on k2 filter page
Hello Jennie,

I don't know what your configuration is right now after moving on to jQuery Easy Profiles, but I would suggest you login in the frontend as Super User and that, in the backend, you set jQuery Easy Profiles to show the report tool for the Super User. This way you will see what the plugin does on the loaded page.

You should get pretty much the same results using jQuery Easy or jQuery Easy Profiles if you don't enable any of the jQuery Easy Profiles extra parameters.

I actually see a javascript error due to the fact that a script is using an old property not available in jQuery v1.12 anymore. Therefore you need to enable Migrate (v1.4.1). Maybe that is the only thing missing here.

Olivier.

Please Log in or Create an account to join the conversation.

More
8 months 2 weeks ago #5083 by jenniedee
Replied by jenniedee on topic jquery issue on k2 filter page
Hello Olivier
thank you for your reply.
The module was actually set to use jquery 1.8 on this page, that I think was the default setting that worked before. So I think it shouldn't need migrate?
However when I looked at the source code on the page it was loading 1.12 which is what the other pages were set to load.
I have assigned the module to the page by the menu setting. I've also tried adding the URL and also assigning it to the Filter component.
I tried enabling migrate anyway but there was no change.
I enabled the support tool but couldn't see any additional information when I navigated to the page.
I decided to go back to the beginning and start again, so I disabled the jquery easy modules and the plugin.
And then I found that everything now works without jquery easy!!!! The filter, the menu and the galleries.
I remain utterly perplexed (not the first time when it comes to jquery), but at least it's all working now.
Yours in total bafflement
Jennie x

Please Log in or Create an account to join the conversation.

More
8 months 2 weeks ago #5084 by syw
Replied by syw on topic jquery issue on k2 filter page
Well, glad it is working now!
Something was probably different when you installed jQuery Easy initially. 
I was gonna offer to take a look but I guess I don't need at the moment :-)
Give it a few more days with testing to make sure everything is working properly.
There is money back in the 30 days after your purchase so if you need a refund, just let me know in a few days! 

Olivier.

Please Log in or Create an account to join the conversation.

More
8 months 1 week ago #5089 by jenniedee
Replied by jenniedee on topic jquery issue on k2 filter page
Thanks for your help Olivier and sorry for late reply. I have been diverted.
I have covered the cost so will hang onto the extension in case of further problems. I have to upgrade K2 so that could rock the boat.
Thanks again
Best regards
Jennie

Please Log in or Create an account to join the conversation.

More
8 months 6 days ago #5090 by syw
Replied by syw on topic jquery issue on k2 filter page
No problem Jennie :-) You are very welcome.

Olivier.

Please Log in or Create an account to join the conversation.