file Specific version just for a module?

More
5 years 11 months ago #3355 by Kevin33
Specific version just for a module? was created by Kevin33
Hi,

I have a j2.5 running virtuemart 2 which has many modules e.t.c.

I have also installed jquery easy set to jquery 1,7. With jquery 1.7 everything works fine except a plugin which works only with jquery 1.6

Is there anything i can do?

Please Log in or Create an account to join the conversation.

More
5 years 11 months ago #3356 by admin
Replied by admin on topic Specific version just for a module?
Hello,

I am afraid the only way is to contact the developer and see what he can do about it. jQuery v1.6 is pretty old now and there may already be an updated version of that plugin that would work with newer versions of jQuery.

You may also try making everything work with v1.6, but I suspect you already tried that.

It is possible to run 2 jQuery versions on a same page however. But it is highly unreliable in Joomla! because you have very little control over the order in which libraries are loaded...

Olivier.

Please Log in or Create an account to join the conversation.

More
5 years 11 months ago #3357 by Kevin33
Replied by Kevin33 on topic Specific version just for a module?
Yeah i have tried everything, and as a last resort i have contacted the developer and asked him if he can make it work with jquery 1.7

Thank you

Please Log in or Create an account to join the conversation.

More
5 years 11 months ago #3358 by admin
Replied by admin on topic Specific version just for a module?
You are welcome. In this case, that is all you can do. There are no major changes between those 2 versions of jQuery so I do not think modifying the code would be a major issue for the developer of the plugin.

Olivier.

Please Log in or Create an account to join the conversation.