Login Form

Login or register to buy licenses or to access software previously purchased.

If you are experiencing login issues, empty your browser's cache and try login from the downloads page. Still having trouble? Please contact us!
×
Postings

You can freely browse the forum. However, you need a valid license in order to post (own a valid commercial software license or have purchased a support membership).

Posts only show after being reviewed.

Topic-icon Compatibility with NoNumber Advanced Module Manage

More
10 months 1 week ago #4506 by imma
Are you aware of any incompatibility between LNEE and NoNumber Advanced Module Manager? I think it has to do with this FAQ:
www.nonumber.nl/extensions/advancedmodul...anced-module-manager

Please Log in or Create an account to join the conversation.

More
10 months 1 week ago #4509 by syw
No, I am not aware of any issue with that extension.
What problems are you experiencing?

Olivier.

Please Log in or Create an account to join the conversation.

More
10 months 1 week ago #4513 by imma
Advanced Module Manager overrides the standard modules component , presents a module manager with some niceties (attachment 1), but above all adds to every module settings an 'Assignments' tab that substitutes for the 'Menu Assignment' one and offers a fine-grained control of when and where the module will display (attachment 2).

Editing LNEE modules with AMM enabled brings a dismal screen (attachment 3) that is basically the unformatted AMM 'Assignments' tab, without access to any other settings.

You can switch back and forth between standard Joomla module manager and AMM, so maybe it would be possible to edit some settings in one environment and the rest in the other: I didn't even tried, as this will be greatly inconvenient.
Attachments:

Please Log in or Create an account to join the conversation.

More
10 months 1 week ago #4515 by syw
I have installed the Advanced Module Manager this morning on a test server and installed the free version Latest News Enhanced without having any problem. Since the code is pretty similar, I did not look further and was waiting for your input to understand what was going on.

I am taking a look right now. I will let you know once I find out what the problem is.

Olivier.

Please Log in or Create an account to join the conversation.

More
10 months 1 week ago #4516 by syw
I have found what the problem is.

Did you install the newsfeed plugin for the module? I assume you did.
There is a test in that plugin that checks if we are in the context of the module manager... But with the Advanced Module Manager, the context is different.

In plugins/latestnewsenhanced/newsfeeds/newsfeed.php, the lines:
if (!in_array($form->getName(), array('com_modules.module'))) {
    return true;
}

must be replaced with
if (!in_array($form->getName(), array('com_modules.module', 'com_advancedmodules.module'))) {
    return true;
}

If you don't feel comfortable changing the code yourself, send me an email and I will send you the file to replace.

All my extensions comply with the Joomla! standard and the Advanced Module Manager replaces a core component with its own. I think it is a mistake for the AMM's developer to assume everyone else's code should comply with his. Without the code I gave you to change, the newsfeeds plugin would never work, despite the fact that it is in no way messing up with the Joomla core, as suggested in the AMM's FAQ...

Olivier.
The following user(s) said Thank You: imma

Please Log in or Create an account to join the conversation.

More
10 months 1 week ago #4518 by imma
Super. Works like a charm now. Thanks.

I assume upcoming revisions will include this change so I don't need to track the override.

syw wrote: ... I think it is a mistake for the AMM's developer to assume everyone else's code should comply with his. Without the code I gave you to change, the newsfeeds plugin would never work, despite the fact that it is in no way messing up with the Joomla core, as suggested in the AMM's FAQ...


You are right. Who will write to them, you or me? I don't own the paid version of AMM.

Please Log in or Create an account to join the conversation.